fd-gentoo/app-emulation/qubes-gui-common/qubes-gui-common-4.2.5.ebuild
Federico Justus Denkena bdf86ef4b6
app-emulation/qubes-gui-common: new package, add 4.2.5, 4.3.0
Signed-off-by: Federico Justus Denkena <federico.denkena@posteo.de>
2024-12-05 14:10:19 +01:00

38 lines
635 B
Bash

# Maintainer: Frédéric Pierret <frederic.pierret@qubes-os.org>
EAPI=7
inherit git-r3 multilib qubes
if [[ ${PV} == *9999 ]]; then
EGIT_COMMIT=HEAD
else
EGIT_COMMIT="v${PV}"
fi
EGIT_REPO_URI="https://github.com/QubesOS/qubes-gui-common.git"
KEYWORDS="amd64"
DESCRIPTION="Common files for Qubes GUI - protocol headers"
HOMEPAGE="http://www.qubes-os.org"
LICENSE="GPL-2"
SLOT="0"
IUSE=""
DEPEND=""
RDEPEND=""
PDEPEND=""
src_prepare() {
qubes_verify_sources_git "${EGIT_COMMIT}"
default
}
src_install() {
insinto 'usr/include'
doins 'include/qubes-gui-protocol.h'
doins 'include/qubes-xorg-tray-defs.h'
}